Server timeouts leading to device boot looping

Incident Report for TRMNL Eink Display

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 20:34 EDT

Update

Still figuring out the cause, but increased latency on our API servers led to repeated timeouts. If your device is not already showing content again, turn it off for 10 seconds to clear the board's buffer and then back on.
Posted Jun 05, 2025 - 20:34 EDT

Update

We are continuing to investigate this issue.
Posted Jun 05, 2025 - 19:58 EDT

Investigating

Investigating, will share more details soon.
Posted Jun 05, 2025 - 19:58 EDT
This incident affected: Display API.