Server timeouts (again) leading to device boot looping

Incident Report for TRMNL Eink Display

Resolved

Posted Jun 05, 2025 - 22:50 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2025 - 22:31 EDT

Investigating

Investigating. Feel free to turn your device off to preserve power, as it may drain your battery while retrying for new content.
Posted Jun 05, 2025 - 21:17 EDT
This incident affected: Display API.