We identified that a change made to the Google Calendar plugin resulted in very long render times for that particular plugin. This delay quickly exhausted our pool of Firefox workers and prevented other plugins from getting a chance to generate. The offending change has been rolled back.
Posted Mar 30, 2026 - 16:50 EDT
Monitoring
We have deployed a fix and worker health has improved. We are continuing to monitor the situation.
Posted Mar 30, 2026 - 16:05 EDT
Update
On our background worker nodes, we have found that Firefox times out during plugin rendering. We are continuing to investigate the cause.
Posted Mar 30, 2026 - 14:09 EDT
Investigating
Some users are reporting that some of their plugins have not updated since about 14:00 UTC. We are investigating.
Posted Mar 30, 2026 - 13:16 EDT
This incident affected: Screen Generation Workers.