TRMNL dashboard downtime

Incident Report for TRMNL ePaper Display

Resolved

This incident has been resolved.
Posted May 05, 2026 - 09:55 EDT

Monitoring

We discovered that an expensive analytics query was running, consuming a large amount of the web server CPU and memory. The query was killed and the server became responsive again. The situation: monitored.
Posted May 05, 2026 - 09:41 EDT

Investigating

The TRMNL dashboard application is intermittently down. The API is still up, so device refresh isn't affected. We're looking into the issue.
Posted May 05, 2026 - 09:21 EDT