Database overloaded

Incident Report for TRMNL ePaper Display

Resolved

A long-running database process (WalSender - Write Ahead Log Sender) was the root cause of extra memory usage and has since finished. We also up-sized the database permanently and removed temporary webhook rate limit reductions.
Posted Nov 23, 2025 - 11:05 EST

Investigating

We’re investigating a database-related issue that prevents our API from responding to some device requests for new content. We have temporarily reduced webhook rate limits to 5 per hour, down from 12 and 30 per hour (TRMNL+ subscribers).
Posted Nov 22, 2025 - 20:07 EST
This incident affected: Display API.