We've manually redeployed workers and systems continue to be stable.
Posted Apr 28, 2026 - 15:34 EDT
Identified
We've identified a commit that failed to properly deploy workers, and a second that affected Redis CPU. These have been reverted and we continue to search for the root cause.
Posted Apr 28, 2026 - 14:52 EDT
Update
We have started to investigate this issue.
Posted Apr 28, 2026 - 14:47 EDT
Investigating
Under investigation
Posted Apr 28, 2026 - 14:46 EDT
This incident affected: Display API, Firmware API, and Screen Generation Workers.