Bad gateway

Incident Report for TRMNL ePaper Display

Resolved

Our Digital Ocean droplet required manual intervention. PUMA crashes. Will investigate how it got into this state.
Posted Aug 19, 2026 - 18:58 EDT

Update

We are continuing to investigate this issue.
Posted Aug 19, 2026 - 18:49 EDT

Investigating

Currently investigating outage to trmnl.com
Posted Aug 19, 2026 - 18:49 EDT